SCCM PXE boot failed after unintall WSUS.

By | October 2, 2016

Setup my test lab in this weekend to test SCCM TP 1609, and my PXE boot failed. SMSPXE.log shows:

RequestMPKeyInformation: Send() failed.
Unsuccessful in getting MP key information. 80004005.
PXE::MP_InitializeTransport failed; 0x80004005
PXE::MP_ReportStatus failed; 0x80070490,
PXE::CPolicyProvider::InitializeMPConnection failed; 0x80070490

 

mplist-failed

When tried to open MP list, http://my_sccm_server/sms_mp/.sms_aut?mplist, it gave me HTTP Error 500.19

mplist failed 2.PNG

Error Code 0x800700e,ย unable to load DLL.

So what happend? Well, because I uninstalled WSUS (not ask my way, I had my reason. ๐Ÿ˜€ ), applicationHost.config files didn't updated itself.

How to fix it:

Open "C:\Windows\System32\inetsrv\config\applicationHost.config", search "suscomp.dll", and remove the whole line.
After that problem sovled.

<scheme name="xpress" doStaticCompression="false" doDynamicCompression="true" dll="C:\Program Files\Update Services\WebServices\suscomp.dll" staticCompressionLevel="10" dynamicCompressionLevel="0" />

iis

Well, you can also install WSUS back, it will fix the problem for you. ๐Ÿ™‚

4 thoughts on “SCCM PXE boot failed after unintall WSUS.

  1. Techy Technician

    OMG I was banging my head against a wall for hours on this one! It fixed things straight away thanks!

    Reply
    1. Zeng Yinghua (Sandy) Post author

      I am glad it helped you. Thanks for your comments. ๐Ÿ™‚

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *